C&C 4 Map Design Notes
Required Steps:

These steps must be completed or the map will either not function or be missing key elements.
· Go to Edit -> Edit Player List/hit Ctrl-Alt-P, and hit the “Add Skirmish Players” button at the bottom of the pop-up window.

· Define 2 trigger areas to be the GDI & Nod Spawn zones.  Name the trigger you want to be the GDI spawn zone TeamManager1_SpawnZone, and the trigger you want to be the Nod spawn zone TeamManager2_SpawnZone.

· These names are built into the drop-down list for area trigger names.

· Create waypoints named Player_#_Start where # is every value from 1 to 10.
· These names are built into the drop-down list for waypoint names.

· These waypoints are what the camera focuses on when you hit ‘R’ when you have no crawler, and tell the game how many player slots to use in the lobby.

· Players 1 through 5 are GDI players.  Place their waypoints in the GDI spawn zone.

· Players 6 through 10 are Nod players.  Place their waypoints in the Nod spawn zone.

· If you want to make a map for less than 10 players, remove the waypoints for players 5 & 10 first, then, 4 & 9, and so on.

· Place goal structures on the map, by hitting the P key, selecting NEUTRAL_STRUCT_GOAL(Goal Structure) (found in ByNativeType -> Neutral -> Structure) and placing the goal objects.  Make sure they’re on the Neutral player.

· An odd number of goals is better than an even number, as it makes it more difficult for the game to enter a stalemate.  
· With more than 5 goals, audio feedback will be misleading and the scorebar will be ugly.
· Place crystal pads and crystal spawn waypoints for each green or blue crystal spawn location.
· Crystal spawning is controlled by waypoints named UpgradeCrystal_# (where # is 1, 2, 3…) and SuperUpgradeCrystal_#.  

· Waypoints named UpgradeCrystal create green crystals; those named SuperUpgradeCrystal create blue crystals.

· Place Crystal pads at these waypoints to reveal the spots where crystals will spawn to all players.

· The crystal pad object is TiberiumLandingPad, found in ByNativeType -> Neutral -> Structure.
Recommended Steps:
· The standard 10 player map size is 660 by 660.  (Set in File -> Resize…).  You really want a square map, so the minimap won’t get distorted.
· Turn on Octagonal Map Borders (View -> Show Octagon Map Boundaries).  This shows you the actual playable area on your map.
· To use the same default camera settings used in C&C 4, set the following values under Edit -> Edit Map Settings -> Camera Behavior
· Min Height: 175

· Max Height: 600

· Pitch Angle: 48

· Yaw Angle: -45

· Standard cliff height is 60 feet.  
· All cliff objects are built to be placed on 60 foot (single-height) or 120 foot (double-height) cliffs. 
· All ramp objects are built for a vertical transition of 60 feet.
· When laying out a map, in order to keep units from going places they shouldn’t, you need to paint both impassability and cliff cells.

· Nothing can enter or land on impassable areas (except aircraft, which can move through them), including cliff-jumping and burrowed units.

· We recommend that you paint all non-playable map areas as impassable, including the corners cut off by the octagon map boundaries.

· Cliff-jumping and burrowed units can traverse cliff cells.

· Worldbuilder automatically paints a thin line of cliff cells based on elevation, but map designers typically need to paint more cliff cells around cliffs to keep units from pathing through the gaps.
· Our convention is that you can cliff-jump over 60 foot height changes but not 120 foot ones.

· Pre-placed faction base defenses should have their controller changed to TeamManager1 (GDI) or TeamManager2 (Nod) after being placed.

· The default GDI & NOD players have no power or AI associated with them, and structures left on those players will be inactive.

· When placing structures & base defenses, we recommend that you turn on the placement grid (Edit -> Enable Placement Grid).
· This should help minimize build & pathing issues later.

· We recommend you only use the following tech structures found in ByNativeType -> Neutral -> Structure (the others are quirky, obsolete, or system objects):

· MUTANT_Struct_Factory (Mutant Hovel)

· NEUTRAL_Struct_AntiAircraft (AA Launcher)

· NEUTRAL_Struct_Blast (Artillery)

· NEUTRAL_Struct_Goal (Goal Structure/TCN Node)

· NEUTRAL_Struct_Utility (Build + Deploy Radius)

· If you assign these structures to a non-neutral player, they don’t function and can’t be captured properly.

· If you’re building a map and want to match the look of an existing region, open the Post Effects panel (Edit -> Edit Post Effects) and click on one of the region preset buttons (i.e. Arctic, PanAmerica, Junktown, etc.)  That will apply the post-effect settings associated with that region to the map.

Design suggestions:
For a standard 5v5 multiplayer map, the following features are highly recommended:

· Pre-placed base defenses around each team’s spawn zone.

· These provide a strong point to retreat to, and make spawn camping more difficult.

· Three “lanes” of conflict.

· For a 5v5 map, having 3 major sections of the map (top, bottom, middle, or left, right, middle), each having roughly balanced importance in terms of goal nodes, tech structures, and crystal spawns, is highly recommended.
· If one section of the map is overloaded with goals or crystal spawns, it can can lead to most or all players focusing on that area, and whichever team holds that area inevitably winning the game.

· Moving between lanes should be relatively easy, both for the sake of pathfinding, and to allow players to retreat from losing battles without waiting several minutes before getting back into the fight.

· Generally, this means that you want 3-4 different paths into every section of the map.

· 5 goals/TCN hubs.

· Less than 5 goals makes it easier for a winning team to turtle and lock down the majority of the goals, and generally slows down the game.  More than 5 goals makes it difficult for a team of 5 players to capture and protect a majority of the goals on the map, and speeds up the game.
· 2+ green upgrade crystal spawns, & 2 blue upgrade crystal spawns.

· This gives both teams a chance at enough crystals to reach Tier 3, and enough spare crystals to use them as weapons.

· Around 4-6 non-goal tech structures.

· Use these, along with Crystal spawns, to make areas of the map which don’t have as many goal structures attractive to players.

· NEUTRAL_Struct_Utility is probably the most generally useful tech structure.
· NEUTRAL_Struct_Blast can be the most powerful, depending on where it’s placed.  Be careful about putting these too close to goal structures or crystal spawns.

· To create a minimap:
· Use Ctrl-F to change to top-down view, and take a screenshot of your map.

· Emphasize the Octagon borders, resize the image to 256 x 256, and save it as a grayscale .tga file.

· To get it to show up as the minimap, the .tga file must be named <MapName>_Art.tga and be in the same folder as the .map file.
Bonus: C&C 4 Map Beautification Process

These notes are what were given to art contractors for C&C 4, and have been essentially left unchanged.
Set Post Effects: 

· Post effects consist of numerical values and effects that are placed in a specific order.  Choose the settings for the region whose tileset you’re using.

Terrain Sculpting: 

· Examine the cliff walls to make sure they are not all straight, adding a few slight curves to these areas that will help the terrain look more natural.  It is essential that this step does not change the design of terrain too much as it could impede game play areas.

· In the non-playable areas and margins of the map, use the terrain height tools to create natural looking mountains.

Place Cliff Geometry: 

· Start adding cliff geometry to entire map.  Mix and matching the cliff geometry will make sure there is not too much repetitiveness.

Place Ramps: 

· Ramp geometry should be centered in their respective spaces.

Place Ambient Terrain Textures: 

· Ambient terrain textures have the letter “A” after the region abbreviation in their name. (For example: ARA_icysnow01.tga is an ambient terrain texture that is meant to be used in the Icy Snow map area within the Arctic region.)

· You may notice areas of bright pink terrain textures on the map. Be sure not to cover these with ambient terrain textures just yet. These are areas marked for Non-Pathable vignettes. More info on that below.

· Using a large brush start placing ambient textures to cover the different areas of the map.

· Be sure to use a variety of textures within a given tier to avoid tiling.

Place V1 Terrain Textures & Roads:

· V1 terrain textures have the designation “V1” after the region abbreviation in their name. (For example: ARV1_icysnow_fracture01.tga is a V1 terrain texture that is meant to be used in the Icy Snow map area within the Arctic region.)
· Using a smaller brush start painting in V1 textures under game play specific structures. (Goal and tech structures, bunkers, base defenses, single player objectives, etc.)

· V1 roads have the designation “V1” after the region abbreviation in their name. (For example: ARV1snowroad01 is a V1 road that is meant to be used in several map areas within the Arctic region.)
· Add the appropriate V1 roads to further “ground” the asset into the terrain as well as adding detail and contrast to lure the player’s attention.

· The V1 tire track roads should lead to and from the goal structures.

· The V1 foot print roads should lead to and from the garrison and neutral tech structures.

Play The Game: 

· At this point, it is a good time to stop and play the map to experience your work firsthand.

· If it is a multiplayer map, you will find it useful to see how the map plays with AI and other human players. Since multiplayer maps tend to be large, this will determine where you will use vignettes to theme parts of the map to help players maintain their sense of location.

· If it is a single player campaign map, play against the AI and try to achieve the mission objectives. This will help you understand how to “frame” the mission beats with vignettes and additional terrain texturing as well as V2 roads. Also, you will learn what parts of the map are most important and be able to focus your remaining work in those areas.

Place Vignettes: 

· Having played the game you should now have a pretty good idea where the combat lanes and mission objectives lie. You can fill the negative spaces between the important game play areas with clusters of props called vignettes. 

· Each region will have its own unique set of 3D objects that will be used to create vignettes. 

· Generally using a prop from one region in a different region is not considered a good idea. 

· Start placing prop assets along the cliff edges then move to the inner map areas that require a vignette that will either be Pathable or Non-Pathable.
Pathable Vignettes are purely artistic and can be placed almost anywhere, however, artists should be selective in where these are placed as they should be used in a way that makes sense.  Pathable vignettes should be used to add interest to an area that may seem too open or sparse.  They can also be a device to draw the player’s eye to a specific game play area of interest.  The use of too many pathable vignettes may become a problem as this will add considerably to the maps overall object count. Objects placed in the pathable vignette area will generally be considered “crushable”; this means that infantry and vehicles will be able to destroy them by running over them or knocking them down.   The terrain beneath a pathable vignette area should not be sculpted.

Non-Pathable Vignettes will be suggested by designers using a bright pink texture. These areas should look like they cannot be accessed by infantry or vehicles. One way of handling Non-Pathable vignettes is by sculpting the terrain within the defined area. This can be handled by either extruding or recessing the terrain and decorating it accordingly.

Place V2 Terrain Textures:

· V2 terrain textures have the designation “V2” after the region abbreviation in their name. (For example: ARV2_icysnow_fracture01.tga is a V2 terrain texture that is meant to be used in the Icy Snow map area within the Arctic region.)

· Using a smaller brush start painting in V2 textures under the various vignettes throughout the map.

Place V2 Roads:

· The last things added to the map are the V2 roads and V2 footprints.
· V2 roads have the designation “V2” after the region abbreviation in their name. (For example: ARV2snowroad01 is a V2 road that is meant to be used in several map areas within the Arctic region.)
· These should be placed on the terrain in a way to guide the player’s eyes around the map in an interesting way. 
· The roads should not be placed in ways that make them look too straight they should have more of a curvaceous look to their implementation.
· They should feel like loose sketch lines on a drawing.
Final Review & Polish:

· Once a map is finished with its beautification pass it is handed back to the designer for a final review of playability.

